Announcement

Collapse
No announcement yet.

X12XE - Rough idle, and really weak engine power after ECU reset.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Corsa B 1993-2000] X12XE - Rough idle, and really weak engine power after ECU reset.

    Hi

    I have been dealing with a hesitation problem on my Corsa for some time now. It's a 2000 Opel Corsa B, with the 1.2 liter 16 valve engine. (x12xe)

    In an attempt to deal with this i tried using my scantool, to perform the following..
    "Reset O2-block learn map"
    "Reset IAC-block learn map"

    After that, everything went bananas..

    Here is a little video of how the engine is running.
    Dropbox - File Deleted

    I am suspecting to O2 loop. Since it never really closes for more than 2 seconds. And when it so does, it seems to be picking op, but then looses again when it goes into open.

    O2 sensor is reading 20mv (very lean..) and it helps putting starter fluid into the air intake - Which also picks up on the O2 sensor reading a lot higher. The sensor is definitely working.

    For the rest of engine data, it can be found in this recording of the engine running. You can also ask me if you suspect anything (since it is a bit overwhelming in that excel format..)
    Dropbox - File Deleted

    The symptoms beside that are:
    - Brake Booster is not working properly (very hard to brake, worked fine before ECU reset)
    - Works fine with no load, and throttle full open.
    - Have a P0505 IAC code, although this seems unrelated, since this happens when pushing the throttle also..
    - Have an intermiddent P0130 code for the O2 reading low, although i have confirmed the O2 sensor is working.
    - Starter fluid improves the rough idling and the whole situation in general.
    - No obvious vacuum leaks.

    So i am here - It is not getting enough fuel.. But why?

    I am really stuck here, any help is really appreciated

  • #2
    If the brake servo isn't working then that could well be your problem. They can break down internally which means you have a vacuum leak which you can't see. That would account for both the loss of servo and the engine issue.
    1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

    Comment


    • #3
      I see your point.

      But when i test the brake booster (pushing the pedal 3-4 times when engine is off, start the engine, and see if the pedal moves down) - the pedal moves down. I don't know if that method is bulletproof, but is there another way to test that? (maybe clogging the vacuum line up to the brakebooster?)

      And many thanks for your suggestion, i am really desperate in solving this issue :3 Thank you.

      Comment


      • #4
        Just tried disconnecting brake booster, and blocking the vacuum with my thumb. - No changed in engine smoothness. :/

        Comment


        • #5
          Solved it by resetting the ECU again. (lol wth)

          Now i still have the original problem yet to be solved.

          The engine gives up on full throttle.

          It sets a fault code for o2 is lean, and when throttle is applied the o2 goes lean.

          I don't know what causes the system to not inject enough fuel. Pressure is ok, and MAF/IAT is reading fine?

          Comment


          • #6
            Either the mag is faulty, they don't last forever and you have to use a genuine item, or there is a vacuum leak after the maf.

            Check also that the exhaust isn't leaking which throw a faulty o2 reading.
            1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

            Comment


            • #7
              The o2 reads fine during idle, and since the engine has a driveability issue, it is likely that they are reading an actualy problem.

              You can see my airflowmeters reading in this document during a hard acceleration with no load. Are they normal?
              Page not found

              It reads 1,5 volts at idle (ToleranceData says: 1,5v at idle and 4,2 volts at hard acceleration) and it never reads more than 3,55 at hard acceleration.

              How is that possible and is this what is causing the problem?
              Last edited by Fresser; 28-06-2016, 06:20 PM. Reason: forgot link

              Comment


              • #8
                Hi Fresser. Did you resolve the issue as I have just replaced the Idle Speed Control Motor and my engine is doing the same as yours ie loses all power and dies when I open the throttle. My manual says to erase the adaptive value settings but I cant find how to do that using Opcom

                Comment

                Working...
                X