Announcement

Collapse
No announcement yet.

Loss of power and sounds like a scooby

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Corsa C] Loss of power and sounds like a scooby

    Got a problem with the corsa, it's started to lack power a bit on acceleration (seems to make noise and not go anywhere) then after that it just takes off.

    It also sounds like a subaru when driving steady (burble from exhaust) never did that before and also sometimes when I accelerate hard and change gear quick it splutters and pops/cracks (from exhaust) thinking that may be plugs or coil pack (will check when car cools down) so, has anyone got any ideas? The car is a Corsa c z20let thanks

  • #2
    My car sounds the exact same. Opcom still says it's the EGR valve.

    Comment


    • #3
      Sold my opcom but did pedal test and came up something to do with aircon lol

      Comment


      • #4
        the fact it pops and burbles from the exhaust suggests it's misfiring for whatever reason.. You may need to have op-com connected whilst driving it to figure out what cylinder is missing, although ususally it would store a code for mis-fire.. does the pedal test not show up all error codes?
        |> Spec2 R33 Skyline GTS-T <|

        Comment


        • #5
          Sound anything like this or similar?

          Comment


          • #6
            Originally posted by Dave View Post
            the fact it pops and burbles from the exhaust suggests it's misfiring for whatever reason.. You may need to have op-com connected whilst driving it to figure out what cylinder is missing, although ususally it would store a code for mis-fire.. does the pedal test not show up all error codes?
            I tthink it could be a misfire also I was told my actuator is set wrong ( I know **** all about them or what they do) but I have a pic if you want to see it, I wI'll try change the plugs soon and maybe the coilpack and no mate that's the only code and strangely it's not the eml what flashes it's the other one (one with spanner on car)
            Originally posted by Sparky View Post
            Sound anything like this or similar?

            Similar mate mines more of a low burble less rasp

            Comment


            • #7
              It's worth checking the state of the exhaust - the engine uses the backpressure from a sound exhaust so if the baffles have gone, or there's a leak, you can get issues - which would also account for the noise of course.
              1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

              Comment


              • #8
                Exhaust is in good condition Taurus, the only baffles it has are in the back box and that's fine, been told my actuator is set wring but not sure how to adjust it to the right setup :/

                Comment


                • #9
                  sounds more liek a misfire tbh. pull the plugs and check the colour of the tips.
                  Rub-A-Dub-Dub

                  Comment


                  • #10
                    As rob said. Should
                    Be obvious which cylinder has the misfire, then take from
                    There

                    Comment


                    • #11
                      Will be checking the plugs today, also what is the unearthing to do with the breather pipe on too left if the engine as all it has on is one for those little filters and it's **** it just leaks oil everywhere

                      Comment

                      Working...
                      X