Announcement

Collapse
No announcement yet.

Vehicle speed sensor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Corsa B 1993-2000] Vehicle speed sensor

    Hello
    I have a Corsa B city 95 1.4, where is the vehicle speed sensor located? Is it the complete speed cluster? I have a code VSS
    Thanks

  • #2
    It's part of the speedometer itself. It sends a signal back to the ECU, so check the wiring as well.
    1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

    Comment


    • #3
      OK Thanks
      But everything seems fine in the cluster? I see correct speed. I will try to remove the negative cable on the battery for 1 hour and try to clear the ECU. At least I read it can be done that way?
      You mention check wiring, from where? I guess if it all works fine in the cluster, just leave it till something goes wrong? Just a bug? Or is this something that is going to go, just a matter of time?
      Can I buy one from the scrap yard or is a ECU reprogramming needed if I install another cluster.

      Comment


      • #4
        The speedo can read correctly but the speed sensor in it isn't sending a signal back to the ECU. The fault can be either in the cluster itself (even if the speedo reads right) or in the wiring between the instrument cluster and the ECU.
        On those you can replace the instrument cluster without needing to reprogramme it so a scrappies is a good option.
        1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

        Comment


        • #5
          Thanks The 1 hr attempt did not work, light still comes on after the temp reaches 90, paper clip test says VSS

          Comment


          • #6
            BY the way, is this something I can just live with, it cost over a 100 GBP here in Norway for one with 177,000 km on it 20,000 more then original, if its just a the EML on I can live with that, its a old beat up car anyway, runs good,super mileage, but if that will cause other issues like ruin the ECU, then I would consider the investment.
            Opinions?

            Comment


            • #7
              It sounds like it could just be wiring from Speedo to ECU. Could have a look for anything obvious?
              Vauxhall Vectra 1.9 CDTi SRi - New Car
              Black 1.2 Corsa SXI Project - Sold
              Aruba Blue 1.0 Corsa Project - Sold

              Comment


              • #8
                The EML will still show if the fault is live, so resetting the ECU by disconnecting the battery won't clear the light if the fault is still present.

                If the car is running OK I'd live with it. What code are you actually getting?
                1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

                Comment


                • #9
                  24 -VSS, I will look at the fire wall to look at the wires, I assume some come out the firewall, I will whip out my ole Haynes to see if it shows
                  I see its needs removing the glove box to look at the wires to the ECU, I will not pull out the cluster to look at wires, I may as well replace it then.
                  Last edited by oraandaberg; 19-05-2014, 10:59 PM.

                  Comment

                  Working...
                  X