Announcement

Collapse
No announcement yet.

Opel Corsa CDTI 1.3 2008, Won't start

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Corsa D] Opel Corsa CDTI 1.3 2008, Won't start

    Hey. So I have an Opel Corsa CDTI 1.3 car and it worked well for over a year, changed the clutch as the old one was almost died and everything was fine until those last two weeks , the car started to not turn on and sometimes i managed to turn it on with 'jump start' method but today unfortunately I couldn't start it as it was in my house. The car doesn't start up after giving ignition, the car speedometer's lights started to turn off and on while doing weird noises inside the car. I also checked out the car battery voltage and it was around 12.78~ V almost 13V while turned off, i also checked out the car front lights and they were working fine. So not sure where is the problem that this car doesn't start. I also provided a footage of what is actually happening after giving ignition. Thanks , any help would be appreciated!

    VIdeo Link:  Corsa CDTI 1.3 2008 NOT STARTING UP after Giving ignition - Album on Imgur (It might be a little loud footage but that's all I managed to get)

  • #2
    These corsa D don't like to be jump started. You've probably blow the BCM module. Its behind the glove box. Sometimes if you just disconnect the plug connectors and re connect them it will work. Failing that you will have to get someone with OP-Com to try and reset it .

    Comment


    • #3
      Originally posted by Restorer View Post
      These corsa D don't like to be jump started. You've probably blow the BCM module. Its behind the glove box. Sometimes if you just disconnect the plug connectors and re connect them it will work. Failing that you will have to get someone with OP-Com to try and reset it .
      Thanks for replying. So I think with that "Jump start" I meant a whole other thing, I meant about "Push-start" the car which worked a couple of times with the help of some of my friends but now i can't even start up my car and still it is doing the "clicking noise" when i try to start the car. Have you checked out the video link I provided? Here you can exactly see and mostly hear what's going with the car. As for information I did the "Jump-start" only once after i bought the car (second hand but a really carried well car, at least it looked so) and it was cuz the battery ran out of electricity and couldn't start it. The thing is that when i try to start the car it maked weird "knocking noises" and the speedometer flashes (like in the video) , but i doubt that it is wrong something with the battery cuz when i try the light they look just fine. Thanks again for replying , i hope i did provided somewhat of needed information, as I didn't had experiences with cars never before cuz i bought it last year.


      Here is the link of the video:  Corsa CDTI 1.3 2008 NOT STARTING UP after Giving ignition - Album on Imgur

      Comment


      • #4
        Yea I did .look at your video. I still think it's a BCM problem . You say you have checked the battery voltage, and its 12volts . What does it drop down to when you turn the key, and try to start it ?

        Comment


        • #5
          Originally posted by Restorer View Post
          Yea I did .look at your video. I still think it's a BCM problem . You say you have checked the battery voltage, and its 12volts . What does it drop down to when you turn the key, and try to start it ?
          Didn't actually managed to do it that way cuz it was night and dark there. But today i called the auto service guy and he said it was something else not really the battery , he took the car into his garage. Anyways thanks for helping.

          Comment

          Working...
          X