Announcement

Collapse
No announcement yet.

X12XE No start! Cranking fine and fuel pressure ok

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Corsa B 1993-2000] X12XE No start! Cranking fine and fuel pressure ok

    First of all Merry Christmas to you and wishing you all a Great New Year ahead!!

    And as s for me, well....as of today developed I have developed a No Start situation

    Car Battery is brand new and speedily cranking away with joyful glee.

    Fuel pump is ok and fuel pressure is being delivered at the fuel rail test valve.

    On trying to start the car, the EML light continually flashes, and I can hear a relay continually clicking from down towards the passenger glove compartment area.

    Its a 1999 Corsa B 1.2, 16valve AUTOMATIC.

    Searching online forums points towards the immobiliser and keys being the possible culprit??

    I have 2 sets of keys and they both provide the same result when I try to start the car now.

    Any ideas on what to check next?

    Do I take the keys to Vauxhall to get something programmed? Apologies I am new to Vauxhalls and the Corsa, but I am a fairly capable mechanic to the level where I can change a head gasket and trace wiring diagrams with a multimeter.

    The only other long shot I had found was to run an Earth from the ECU to the Battery negative, which someone on another forum had success with. Simple to try.

    Thank you all, I hope someone can help or offer some suggestions here?
    Kind Regards,
    Del75

  • #2
    Welcome

    The flashing EML is as you have said usually an immobiliser problem. Assuming you haven't changed anything since it last ran, and both keys worked the car before but not now, then either the transponder around the ignition switch has been damaged, or there's an ECU fault. Which is why making a good earth on the ECU can sometimes sort it out.

    The system works by cutting off the fuel supply, and the fuel pump relay is in the area by the glovebox. The thing is that usually if that is switched off you won't hear it clicking constantly, and there won't be fuel pressure at the rail. There is a priming run to provide initial pressure when you first turn the key, then the fuel relay switches off until the crankshaft sensor tells the ECU to activate the fuel relay again. So check for pressure after cranking as well as before. Pressure before cranking but not after says the pump isn't being operated.

    Some other thoughts to throw into the pot........

    Being an automatic can complicate things of course. There have been similar issues in the past and I seem to recall the inhibitor switch on the transmission proved to be the problem. I can't remember if it cause the EML to flash or not - I don't see why it would, but worth mentioning.

    Check also the injector relay which is next to the fuel pump relay - it won't tie in to the EML flashing, but if there's fuel pressure in the rail and none reaching the cylinders a dud injector relay can be the fault.


    EDIT - I am assuming this car was running fine before - using the two keys you mention?
    Taurus
    'VXR' Member
    Last edited by Taurus; 29-12-2013, 03:31 PM.
    1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

    Comment


    • #3
      Thank you for sharing your expert knowledge and wisdom Taurus.

      Yes, the car has been working OK and running fine, with both keys.

      I have no fuel spray at all before cranking. That means with the key in and the ignition and dash lights ON. I checked with multimeter have no power sent to the fuel pump at that time also. Months back, I do recall hearing the fuel pump prime at this stage. Now there is nothing.


      After cranking, there IS fuel spray.

      During cranking I am getting around 10.5volts at the fuel pump but it fluctuates between 8v, 9v, and 10v whilst cranking.


      Having removed the glovebox, I've found a set of 5 relays over to the left. It is the furthest purple relay (closest to the engine bay) is the one that is continually clicking during engine cranking. I am guessing that is the Fuel Pump Relay. I've tried replacing this relay but the result is the same. A jumper from pins 30 to 87 gives no difference. Haynes appears to be way off on fuses and relays unless I was on the wrong page.


      The relay next to that purple one is a larger black relay. Is that the injector relay Taurus?



      Also after running an extra earth to the ECU the difference is that during cranking the EML stays constantly ON now, whereas yesterday it would flash whilst cranking. The same purple relay still clicks away.


      As the Car is a X12XE - 1.2 16v I understand that the paperclip test won't work.


      I am thinking that perhaps the ECU may be the cause of this problem. I have not yet managed to locate or check the Auto gearbox inhibitor switch.
      del75
      'LS' Member
      Last edited by del75; 30-12-2013, 08:36 PM.

      Comment


      • #4
        Here is a link to the Inhibitor switch fix:

        Fixing the Vauxhall Flashing “S” of Doom… | Karl's Random Rambling.

        Comment


        • #5
          The fuel injector relay is a duplicate of the fuel pump one. They used the same relay for both circuits. When you bridged pins 30 to 87 are you sure it was the fuel pump relay and not the fuel injector relay you jumped? Since they're identical you may have bridged the injectors rather than the fuel pump. I'd double check that and just to make sure you have tried jumping the right relay. (Those voltage readings at the fuel pump aren't right.)

          Just check that the black wire running across the bottom of the glovebox recess is an original installation. It looks a bit odd - just in case someone's fitted an over-ride switch as a security measure. I've known a few random non-started being due to an unknown switch that gets knocked.

          This is where I'd put it on Opcom and monitor the live data, and also use the facility to remotely trigger the fuel pump relay. That makes it a lot simpler to work through this issue one step at a time. See if there's anyone near you with Opcom who'd hook it up for you.

          Just to confirm - you can't paperclip or pedal test these, it has to be a reader. And the Haynes is wrong about the relay positions so ignore it.
          1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

          Comment


          • #6
            Ok thanks Taurus, Opcom it will be! I'll ask in the Electrical thread if someone lives nearby.
            *High Fives*

            Comment


            • #7
              Quick question, did you check that wire Taurus mentioned!

              Also does the car have an alarm
              Fitted to it?

              Comment


              • #8
                Also - I'm sure you've done this, check you battery voltage. It doesn't sound likely from what you have said is happening, but sometimes a weak voltage can do silly things to them.
                1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

                Comment


                • #9
                  Hi Guys,

                  That photo above is actually not of my car, just a pic i googled with the exact same relay setup. Apologies if it was misleading, I should have mentioned this initially.

                  The previous owner of my corsa fitted a remote fob system to the central locking system. The fobs look like this:
                  Universal Upgrade Remote Keyless For Central Lock

                  From research, it doesn't seem to interfere with any other functions. Central Locking, and hazard light connections only. This all seems to function as normal, when tested.

                  There is no alarm fitted to the car. Battery is new. Voltage is checked and strong. Cranking amps are readily available too.

                  Comment


                  • #10
                    I had about 6 months of not starting after my alarm decided to cut the fuel supply

                    Comment


                    • #11
                      Hey Vegas, what make/model alarm did you have and how did it go about cutting the fuel supply?
                      Cheers

                      Comment


                      • #12
                        THINK it was laserline, that was ages ago though, have a new alarm now

                        Comment


                        • #13
                          I fitted hawk central locking to my Corsa. Absolutely awful, ended up being locked out of the car, several times, had to break into it, setting the alarm off, then of course I still couldn't disarm it so had to rip the wires out of the control unit. Awful piece of kit, wouldn't recommend hawk to anyone.

                          Get rid IMO.
                          |> Spec2 R33 Skyline GTS-T <|

                          Comment


                          • #14
                            I've pluggged in the OP-COM and have the following fault code:

                            P0335 - (0) No Engine RPM Signal - Present

                            I can activate the the Fuel Pump Relay through the software. It runs the Pump OK.

                            Searching online with google gave no definitive answer so far.

                            Any ideas here folks?

                            thanks
                            Del75

                            Comment


                            • #15
                              P0335 would point to the crankshaft sensor - which triggers the fuel pump relay. But it depends how you do the reading because if the engine isn't turning then P0335 will be generated simply because the crankshaft sensor isn't seeing the engine running. And a dud crankshaft sensor doesn't always throw P0335 anyway. ie - it isn't a precise as you'd wish it to be.

                              Just to make clear - the system is that when you turn the ignition key to position 2 the fuel pump relay operates to provide a priming pump of fuel to the fuel rail. It then shuts off until the crankshaft sensor sees the engine turning and tells the ECU to trigger the fuel pump relay to pump fuel. The usual way to tell is the crankshaft sensor has failed is no pressure at the fuel rail after cranking. In your first post you said fuel pressure was present at the rail - which would appear to suggest this system is working OK.

                              Crankshaft sensor failure doesn't cause the EML to flash - which was another of your initial symptoms. That's usually an immobiliser issue.

                              To double check I'd go through the usual check of leaving the car for an hour or so to allow fuel pressure to drop. Then turn the key to position 2 but don't crank the engine. Check for fuel pressure at the rail. There should be good pressure. Then crank the engine. After cranking check again for fuel pressure at the rail. Again there should be good pressure.
                              A. If there isn't then suspect crankshaft sensor failure.
                              B. If there is then check if the plugs are wet - they should be. If not maybe the injector relay has failed.

                              Crankshaft sensors are a very common failure - they're cheap but slightly awkward to get at (under the starter motor at the inboard end of the o/s driveshaft.
                              1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

                              Comment

                              Working...
                              X