Announcement

Collapse
No announcement yet.

Battery woes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Corsa B 1993-2000] Battery woes

    Battery been on charge for about an hour, thought I'd use multimeter to check power.


    It's now up to 13v but is dropping is as I look at it? This because I've just taken off charge? Or something else?

  • #2
    Sorry to hijack but it's related.

    How you checking your voltage with multimeter?

    What's the correct level/v of an idle batt and while engine running?

    Want to check mine and see if it needs replacing.
    Vauxhall Vectra 1.9 CDTi SRi - New Car
    Black 1.2 Corsa SXI Project - Sold
    Aruba Blue 1.0 Corsa Project - Sold

    Comment


    • #3
      14v something with engine running, used a voltmeter to check.

      Could you please start your own thread, as this one could get bit complicated and I'm not great with electrics. So I don't want anymore confusion, or different answers going to different people

      Comment


      • #4
        I just wanted the basic voltage level (should be) thought you would be asking for same thing.

        Will do once I get a reading
        Vauxhall Vectra 1.9 CDTi SRi - New Car
        Black 1.2 Corsa SXI Project - Sold
        Aruba Blue 1.0 Corsa Project - Sold

        Comment


        • #5
          Put battery on after around an hour charging, started straight up.

          Checked voltage and was 11 something slowly dropping too so it's not being charged obviously

          Comment


          • #6
            could it be losing charge quicker than its getting it?
            .

            Comment


            • #7
              Originally posted by Shaggy View Post
              I just wanted the basic voltage level (should be) thought you would be asking for same thing.

              Will do once I get a reading
              13 odd

              - - - Updated - - -

              Id reckon cell's have **** themselves

              Comment


              • #8
                What that to me or Shaggy? This is why I hate other questions in threads

                Comment


                • #9
                  Mark you bought and fitted a new alternator that you won, was the battery new or old?

                  Comment


                  • #10
                    Battery was new in June, day before PVS.

                    The alternator was. A recon

                    Comment


                    • #11
                      Id reckon cell's have **** themselves

                      is to you mark... drive it round to an auto electrical place and blag youre thinking of getting your alternator refurbed and would they test it (both the battery and alternator)

                      Comment


                      • #12
                        Originally posted by Vegas View Post
                        Battery was new in June, day before PVS.

                        The alternator was. A recon
                        Was it a recon off ebay? As they use cheap **** chinese parts. Batterys can also have the same problem, when I had my own garage we fitted cheapo's from a supplier and had most back within a month screwing at me.

                        Comment


                        • #13
                          This is my earth from chassis to alternator, I take it that's fine?

                          /0A35AFE9-22A8-4C59-A785-BB670859A3B7_zpsnxqebgnh.jpg.html]"]Photobucket



                          I took alternator belt off, when did sump as I had to remove oulley

                          Comment


                          • #14
                            Let's not et ahead of ourselves here.

                            Give from battery cells to faulty alternator in one post.

                            It was from eBay, but wasn't one of te Chinese sellers, was a private seller, and whole thing had been rebuilt.

                            Battery will just be tested same as I've done, under load and when it's off the car?

                            Comment


                            • #15
                              I know mine is 11.6 with ignition on and 13.8 when car is running as I have just nipped out and checked for you lol. Is it possible to use daily hacks battery and see if results change. And your earth looks spot on from photo.

                              Comment

                              Working...
                              X