Announcement

Collapse
No announcement yet.

Indicator not working, Please help.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Corsa B 1993-2000] Indicator not working, Please help.

    I have recently installed morettes on my Corsa b, while installing side repeaters were going to be used as indicators but due to the 5w bulbs were too fast and were popping the fuses when the hazards were pressed. Since then i have replaced the side repeaters with 21w standard GM indicators which stopped the tripping of fuses, but as is my indicators wont work, when i flick the stalk there is no tick from the relay and no light on the dash. While the hazard lights are activated there is clicking from the relay but no green light on the dials. Anyone got any idea what could have happened?

  • #2
    Checked for any all blown fuses? Maybe blown more then just bulbs and light fuses?

    That's as far as my help goes I'm afraid.
    Aaron
    'VXR' Member
    Last edited by Aaron; 31-10-2013, 11:03 PM.
    Vauxhall Vectra 1.9 CDTi SRi - New Car
    Black 1.2 Corsa SXI Project - Sold
    Aruba Blue 1.0 Corsa Project - Sold

    Comment


    • #3
      Originally posted by Shaggy View Post
      Checked for any all blown fuses? Maybe blown more then just bulbs and light fuses?

      That's as far as my help goes I'm afraid.
      Yeah checked all fuses replaced all four relays and the stalk and still nothing :/

      thanks anyway

      Comment


      • #4
        I'd recheck wiring, make sure something is t shorting

        Comment


        • #5
          Fixed it, was a loose connection in the stalk plug. working now though

          Comment

          Working...
          X