Announcement

Collapse
No announcement yet.

Indicators/brakes/hazard

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Corsa B 1993-2000] Indicators/brakes/hazard

    Hi been having a few problems with my corsa, started off with me noticing my indicators had stopped working one day on my way back from work didn't have any fuses on me so left it till the next day to sort it as I did not finish work till 10pm.

    Next day go to set off to garage/shop but could not get my car to move (automatic) it was stuck in park! Phoned a mobile mechanic and he sorted my car said my brake lights had gone also thats why I could not get it out of park and into drive, he changed fuses and brake bulb and car was fine.

    A week later same thing happened! Mechanic came out and had a look suggested my hazard switch wad faulty... changed hazard switch still no luck, then he noticed one of my rear indicators was dim and now saying it could be a faulty connection.....

    Car is still not fixed just wondering if anyone has had a similar problem and what else it could be?

  • #2
    What year/model/engine?

    Comment


    • #3
      2000 club 1.2

      Comment


      • #4
        Sounds like a bad earth - when the dim indicator flashes are any of the other bulbs also lighting up dimly? (You may need to look in the dark to notice.)

        If the rear lights fail it does scupper the electronics for the auto transmission - might sound like a weird fault but it's quite common.
        1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

        Comment


        • #5
          The right side indicator is dim the left is fine, the lights on the dash dims on and off when the right indicator is on.

          Comment


          • #6
            It's the bulbs adjacent in the cluster you need to check - an earth leak usually causes one or more of them to glow dimly as the indicator goes on & off.
            1972 Viva restoration thread - http://www.thecorsa.co.uk/projects-b....html#post1534

            Comment


            • #7
              Thankyou, got a auto electrician coming out tomorrow to have a look hopefully wont cost too much :/

              Comment


              • #8
                Finally got sorted it was a faulty connection on my indicators, had to be re wired and rerouted

                Comment

                Working...
                X