Announcement

Collapse
No announcement yet.

Corsa d electric window issue after washing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Corsa D 2006-2014] Corsa d electric window issue after washing

    Hi chaps, my 2008 Corsa D was cleaned thoroughly earlier by my local wash and since then my passenger window has an issue. It only winds down when the key is put into the ignition and both switches (driver side and pass side) don't work however the driver side window works fine! Is this a common Corsa fault?

  • #2
    I wonder if somehow some water got down to the motor - that shouldn't happen though.
    Does the car have electric mirrors, and if so do they work on the passenger side? I wonder if that model has a kind of plug between the door and the car (never had a Corsa D) and that just needs tightening up.


    Comment


    • #3
      I'll certainly have a look in the morning about the mirrors!

      Comment


      • #4
        Originally posted by benjiv50 View Post
        I'll certainly have a look in the morning about the mirrors!
        Check the wires that run between the car and the door whilst you're looking at it as it's perhaps a quick fix, they'll be in some kind of rubber protector. I wonder if they cleaned the door shuts and dislodged it - I think it's a kind of large plug with a threaded end to tighten it in.


        Comment


        • #5
          Legend that sounds promising I'll have a look thanks for the help

          Comment


          • #6
            I have a similar problem, when I run the passenger window down, it runs to the bottom and blows the fuse. When the fuse is replaced the window can be closed.

            Comment


            • #7
              Sounds like it's shorting something, it might be worth removing the door panel and inspecting the wires to make sure they're covered as they should be. Also you should check that the drain holes at the bottom of the doors aren't blocked so any water can drop out of the bottom of the door.


              Comment


              • #8
                it seems that it was the window switch which I replaced and it seems to of fixed it!

                Comment


                • #9
                  Originally posted by benjiv50 View Post
                  it seems that it was the window switch which I replaced and it seems to of fixed it!
                  Great news, it's not always so simple!


                  Comment

                  Working...
                  X