Results 1 to 2 of 2

Thread: tigra 1997 1.6 ecotec high c02 mot fail

  1. #1
    'LS' Member
    Join Date
    Aug 2013
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    tigra 1997 1.6 ecotec high c02 mot fail

    Hi all
    hope someone can point me in the right direction here
    here is the story so far
    car has failed mot
    on the fast idle c02 for the first time ever never had a issue before

    car has done 58,000
    no
    smoke from exhaust, car drives great
    choke appears to work
    fine 1200 ish revs drops to 800rpm within a few mins
    does
    backfire(once) when on choke when you take foot of gas and revs drop

    once choke is off no more backfire sounds fine and revs up and drops to 800 rpm no issues

    Natural idle test pass 0.34% max 0.50%

    fast idle test1 fail 0.66% max 0.30%
    fast
    idle test2 fail 0.73% max 0.30%
    hc pass 82ppm max 200ppm

    lambda 1.01 pass max 1.03

    so after this I worked on car changed items
    below

    removed air filter (looked very
    clean)
    new aftermarket lambda sensor 30
    new aftermarket cat 40
    redex in fuel
    and blasted it down motorway car rev's great right upto the
    redline 6500 and beyond 7000rpm in 2nd 3rd 4th etc

    took car for emissions retest still failed

    new c02 0.56% on fast idle
    new low natural idle 0.07% so the air filter removal helped
    there I guess
    new hc 94-121ppm gone up but still a pass
    new lambda 1.00 down 0.01

    worked on car again
    changed new plugs
    changed oil and oil filter
    air filter still
    removed
    more redex another motor way blast
    then back for another test
    exactly the same
    c02 readout 0.56%

    surprised that
    plugs,oil and oil filter made no difference at all

    now i am clutching at straws
    is there another sensor that could be faulty


    read about a engine temp sensor
    where is that and would that not effect the choke ie not make choke turn off

    mot mechanic had no idea and he is not daft
    but just did not know
    thinks I should take of the head and de
    choke or I have a sticking value
    but i just cant believe
    that

    any advice most welcome

    cheers Colin

  2. #2
    'VXR' Member Taurus's Avatar
    Join Date
    Jul 2013
    Location
    Chester
    Posts
    2,464
    Thanks
    43
    Thanked 427 Times in 370 Posts
    A weak CTS (coolant temp. sensor) will keep the fuel/air mix too rich which could be the issue. They are between 10-15 so pretty cheap to replace just to make sure. The HC readings suggest that's worth trying.
    1972 Viva restoration thread - [url]https://www.thecorsa.co.uk/projects-builds/138-1972-vauxhall-viva.html#post1534[/url]

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •